If you are running Internet Explorer 8.0, you must click on the compatibility button to get the log in screen.

This site requires Internet Explorer 7.0 or above, and a minimum screen resolution of 800 by 600.

If you are not prompted with a logon screen then you need to update to Internet Explorer to 7.0 or above.

1. Internet Explorer should be version 7.0 or above.

2.Check Popup blocker software. (If you have a popup blocker installed, you will need to allow popups from abes.ibsa.org/ebc or disable the popup software when logging in. If you have questions concerning this contact IBSA Information Services during regular business hours.)

ABES Support - 217-786-2600 x113

If you suspect a popup blocker, these instructions may help.

If you do not have Internet Explorer you will need to install it to enter the site.